summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.1.1.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.0.2.bb)8
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch34
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb2
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch12
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20191006.bb (renamed from meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20190630.bb)5
5 files changed, 49 insertions, 12 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.0.2.bb b/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.1.1.bb
index 79d1dada04..a5aa584f5a 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.0.2.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_8.1.1.bb
@@ -10,9 +10,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0531457992a97ecebc6975914a874a9d"
UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
SRC_URI = "http://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
- file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch"
-SRC_URI[md5sum] = "c0375a1f725f1c191b43af60e4f7175b"
-SRC_URI[sha256sum] = "33a26ad561546cd2cfe1e6de6352a85df72b41c37def8c7eb00e90e57c627a5c"
+ file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
+ file://0001-dhcpcd-Fix-build-error-with-musl.patch"
+
+SRC_URI[md5sum] = "dc4f29a62afc53cdac311e925cfd1bc7"
+SRC_URI[sha256sum] = "485d308fe10febd36b6f936e4260e4ab34a146e4f00a9f7a5509c4377ad5ea82"
inherit pkgconfig autotools-brokensep
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch b/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch
new file mode 100644
index 0000000000..b48b467b8c
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/dhcpcd/files/0001-dhcpcd-Fix-build-error-with-musl.patch
@@ -0,0 +1,34 @@
+Subject: [PATCH] dhcpcd: Fix build error with musl.
+
+Re-organize the header includes in if-linux.c to fix error as follows:
+In file included from if-linux.c:49:
+path/usr/include/netinet/if_ether.h:112:8: error: redefinition of 'struct ethhdr'
+
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
+---
+ src/if-linux.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/if-linux.c b/src/if-linux.c
+index fd47278..bfa878b 100644
+--- a/src/if-linux.c
++++ b/src/if-linux.c
+@@ -37,6 +37,7 @@
+ #include <linux/if_addr.h>
+ #include <linux/if_link.h>
+ #include <linux/if_packet.h>
++#include <netinet/if_ether.h>
+ #include <linux/if_tun.h>
+ #include <linux/if_vlan.h>
+ #include <linux/filter.h>
+@@ -46,7 +47,6 @@
+
+ #include <arpa/inet.h>
+ #include <net/if.h>
+-#include <netinet/if_ether.h>
+ #include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <net/route.h>
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb b/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb
index 8c95bbae3d..31e6978d6f 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb
@@ -230,3 +230,5 @@ FILES_${PN} =+ "${libdir}/rlm_*.so* ${libdir}/proto_*so*"
RDEPENDS_${PN} += "perl"
RDEPENDS_${PN}-utils = "${PN} perl"
+
+CLEANBROKEN = "1"
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch b/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch
index cd4291d91b..e33d8eac1d 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch
+++ b/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/files/0001-Add-OpenEmbedded-cross-compile-case.patch
@@ -3,17 +3,15 @@ From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 22 Dec 2018 18:47:45 -0800
Subject: [PATCH] Add OpenEmbedded cross compile case
-Upstream-Status: Pending
+Upstream-Status: Submitted [https://github.com/miniupnp/miniupnp/pull/410]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
genconfig.sh | 11 +++++++++++
1 file changed, 11 insertions(+)
-diff --git a/genconfig.sh b/genconfig.sh
-index dc42462..59922e9 100755
--- a/genconfig.sh
+++ b/genconfig.sh
-@@ -98,6 +98,12 @@ if [ -f ../shared/tomato_version ]; then
+@@ -103,6 +103,12 @@ if [ -f ../shared/tomato_version ]; then
OS_VERSION="Tomato $TOMATO_VER"
fi
@@ -26,14 +24,14 @@ index dc42462..59922e9 100755
${RM} ${CONFIGFILE}
echo "/* MiniUPnP Project" >> ${CONFIGFILE}
-@@ -318,6 +324,11 @@ case $OS_NAME in
+@@ -346,6 +352,11 @@ case $OS_NAME in
echo "#define USE_IFACEWATCHER 1" >> ${CONFIGFILE}
- FW=netfilter
+ FW=iptables
;;
+ OpenEmbedded)
+ OS_URL=http://www.openembedded.org/
+ echo "#define USE_IFACEWATCHER 1" >> ${CONFIGFILE}
-+ FW=netfilter
++ FW=iptables
+ ;;
AstLinux)
OS_URL=http://www.astlinux.org/
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20190630.bb b/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20191006.bb
index 6b8fdca4c3..81bfe66a9e 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20190630.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/miniupnpd/miniupnpd_2.1.20191006.bb
@@ -15,8 +15,8 @@ SRC_URI = "http://miniupnp.tuxfamily.org/files/download.php?file=${BP}.tar.gz;do
file://miniupnpd.service \
file://0001-Add-OpenEmbedded-cross-compile-case.patch \
"
-SRC_URI[md5sum] = "394e676f555d8047be69730d9c4d23a5"
-SRC_URI[sha256sum] = "29f49fe6868597d041ee29f511fa7b65781b9e4e85ef2569a2381c2079e1743e"
+SRC_URI[md5sum] = "340789edd49c113afe37834cc901a1e8"
+SRC_URI[sha256sum] = "218fad7af31f3c22fb4c9db28a55a2a8b5067d41f5b38f52008a057a00d2206d"
IPV6 = "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '--ipv6', '', d)}"
@@ -26,6 +26,7 @@ do_configure_prepend() {
do_compile() {
cd ${S}
+ CONFIG_OPTIONS="${IPV6} --leasefile --vendorcfg" oe_runmake -f Makefile.linux config.h
CONFIG_OPTIONS="${IPV6} --leasefile --vendorcfg" oe_runmake -f Makefile.linux
}