summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-filter
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-filter')
-rw-r--r--meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb21
-rw-r--r--meta-openembedded/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.9.bb (renamed from meta-openembedded/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.8.bb)2
-rw-r--r--meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.8.bb (renamed from meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.7.bb)6
3 files changed, 25 insertions, 4 deletions
diff --git a/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb b/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb
new file mode 100644
index 0000000000..95e48f0131
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-filter/ipset/ipset_7.9.bb
@@ -0,0 +1,21 @@
+# Copyright (C) 2017 Aaron Brice <aaron.brice@datasoft.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Administration tool for IP sets"
+HOMEPAGE = "http://ipset.netfilter.org"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+SECTION = "base"
+
+DEPENDS = "libtool libmnl"
+
+SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
+SRC_URI[sha256sum] = "b75c13689eddf1d95b396840a69dc04fd7ae4112b10b70594bc0405df7b9b30a"
+
+inherit autotools pkgconfig module-base
+
+EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
+
+RRCOMMENDS_${PN} = "\
+ kernel-module-ip-set \
+"
diff --git a/meta-openembedded/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.8.bb b/meta-openembedded/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.9.bb
index f1fd61be7b..5532af8d9c 100644
--- a/meta-openembedded/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.8.bb
+++ b/meta-openembedded/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.9.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=79808397c3355f163c012616125c9e26"
SECTION = "libs"
DEPENDS = "libmnl"
-SRCREV = "b2cd6d28fab02934c4ddff0699718d74272eccd3"
+SRCREV = "c3fdda6ac8675aea9b35772458544f03157be415"
SRC_URI = "git://git.netfilter.org/libnftnl \
file://0001-avoid-naming-local-function-as-one-of-printf-family.patch \
"
diff --git a/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.7.bb b/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.8.bb
index e5dfef92bd..6990ae3aeb 100644
--- a/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.7.bb
+++ b/meta-openembedded/meta-networking/recipes-filter/nftables/nftables_0.9.8.bb
@@ -10,11 +10,11 @@ DEPENDS = "libmnl libnftnl bison-native \
UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2"
-SRC_URI[sha256sum] = "fe6b8a8c326a2c09c02ca162b840d7d4aadb043ce7a367c166d6455b0e112cb0"
+SRC_URI[sha256sum] = "60fc004656dae4fefc4901c939c9d64120b4dedb49738e420a9a34989f108fe4"
inherit autotools manpages pkgconfig
-PACKAGECONFIG ??= "python readline"
+PACKAGECONFIG ??= "python readline json"
PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
@@ -28,4 +28,4 @@ RRECOMMENDS_${PN} += "kernel-module-nf-tables"
PACKAGES =+ "${PN}-python"
FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
-RDEPENDS_${PN}-python = "python3-core python3-json"
+RDEPENDS_${PN}-python = "python3-core python3-json ${PN}"