summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-protocols/babeld/babeld_1.12.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-protocols/babeld/babeld_1.12.2.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-protocols/babeld/babeld_1.12.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-protocols/babeld/babeld_1.12.2.bb b/meta-openembedded/meta-networking/recipes-protocols/babeld/babeld_1.12.2.bb
new file mode 100644
index 0000000000..03db5fc0bf
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-protocols/babeld/babeld_1.12.2.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Babel is a loop-avoiding distance-vector routing protocol"
+DESCRIPTION = "\
+Babel is a loop-avoiding distance-vector routing protocol for IPv6 and \
+IPv4 with fast convergence properties. It is based on the ideas in DSDV, AODV \
+and Cisco's EIGRP, but is designed to work well not only in wired networks \
+but also in wireless mesh networks, and has been extended with support \
+for overlay networks. Babel is in the process of becoming an IETF Standard. \
+"
+HOMEPAGE = "https://www.irif.fr/~jch/software/babel/"
+SECTION = "net"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=411a48ac3c2e9e0911b8dd9aed26f754"
+
+SRC_URI = "gitsm://github.com/jech/babeld.git;protocol=https;branch=master"
+SRCREV = "a9fba0e19ebde96cdc4edd35c5363f9e8139ab35"
+
+UPSTREAM_CHECK_GITTAGREGEX = "babeld-(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
+
+do_compile () {
+ oe_runmake babeld
+}
+
+do_install () {
+ oe_runmake install.minimal TARGET=${D} PREFIX=${root_prefix}
+}
+