summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb20
1 files changed, 7 insertions, 13 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb b/meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb
index b34c186ca5..9a2b5ede27 100644
--- a/meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb
+++ b/meta-openembedded/meta-networking/recipes-support/libtevent/libtevent_0.14.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://tevent.samba.org"
SECTION = "libs"
LICENSE = "LGPL-3.0-or-later"
-DEPENDS += "libtalloc libtirpc"
+DEPENDS += "libtalloc libtirpc cmocka"
RDEPENDS:python3-tevent = "python3"
export PYTHONHASHSEED="1"
@@ -11,10 +11,9 @@ export PYTHONHASHSEED="1"
SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
file://0001-Add-configure-options-for-packages.patch \
file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
+ file://run-ptest \
"
-SRC_URI:append:libc-musl = " file://cmocka-fix-musl-libc-conflicting-types-error.patch"
-
LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=47386b7c539bf2706b7ce52dc9341681"
SRC_URI[sha256sum] = "ef85fcaa80ffd2351036ba4b347630fef2a1ac3da964a7f1820466bad03cd00d"
@@ -42,27 +41,22 @@ export WAF_NO_PREFORK="yes"
EXTRA_OECONF += "--disable-rpath \
--disable-rpath-install \
- --bundled-libraries=cmocka \
+ --bundled-libraries=NONE \
--builtin-libraries=replace \
--with-libiconv=${STAGING_DIR_HOST}${prefix}\
--without-gettext \
"
-do_install:append() {
- install -Dm 0755 ${B}/bin/test_tevent_trace ${D}${bindir}/test_tevent_trace
- install -Dm 0755 ${B}/bin/test_tevent_tag ${D}${bindir}/test_tevent_tag
- install -Dm 0755 ${B}/bin/replace_testsuite ${D}${bindir}/replace_testsuite
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ install -m 0755 ${B}/bin/test_tevent_* ${D}${PTEST_PATH}/tests/
+ install -m 0755 ${B}/bin/replace_testsuite ${D}${PTEST_PATH}/tests/
}
PACKAGES += "python3-tevent"
RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
-FILES:${PN} += "${libdir}/tevent/*"
-FILES:${PN}-ptest += "${bindir}/replace_testsuite \
- ${bindir}/test_tevent_tag \
- ${bindir}/test_tevent_trace \
- ${libdir}/libcmocka-tevent.so"
FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"