summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/conf/layer.conf')
-rw-r--r--meta-openembedded/meta-oe/conf/layer.conf14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/conf/layer.conf b/meta-openembedded/meta-oe/conf/layer.conf
index bad87850e9..adcec83029 100644
--- a/meta-openembedded/meta-oe/conf/layer.conf
+++ b/meta-openembedded/meta-oe/conf/layer.conf
@@ -23,13 +23,20 @@ BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_openembedded-layer = "6"
+# only activates content when identified layers are present,
+# to ensure yocto compatibility check pass
+BBFILES_DYNAMIC += " \
+meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
+perl-layer:${LAYERDIR}/dynamic-layers/perl-layer/recipes-*/*/*.bb \
+"
+
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_openembedded-layer = "1"
LAYERDEPENDS_openembedded-layer = "core"
-LAYERSERIES_COMPAT_openembedded-layer = "thud warrior zeus"
+LAYERSERIES_COMPAT_openembedded-layer = "thud warrior zeus dunfell"
LICENSE_PATH += "${LAYERDIR}/licenses"
@@ -49,11 +56,13 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
usb-modeswitch-data->usb-modeswitch \
lmsensors->lmsensors-config \
phoronix-test-suite->bash \
- phoronix-test-suite->python \
+ phoronix-test-suite->python3 \
phoronix-test-suite->php \
phoronix-test-suite->lsb-release \
phoronix-test-suite->util-linux \
phoronix-test-suite->busybox \
+ phoronix-test-suite->shared-mime-info \
+ phoronix-test-suite->desktop-file-utils \
"
# ttf.inc inherits fontcache which adds fontconfig-utils to RDEPENDS
@@ -70,6 +79,7 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
ttf-liberation-sans-narrow->fontconfig \
ttf-lklug->fontconfig \
ttf-lohit->fontconfig \
+ ttf-noto-emoji->fontconfig \
ttf-pt-sans->fontconfig \
ttf-roboto->fontconfig \
ttf-mplus->fontconfig \