summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.6.1.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.6.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.6.1.bb b/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.6.1.bb
new file mode 100644
index 0000000000..91450e2c77
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/gensio/gensio_2.6.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
+HOMEPAGE = "https://github.com/cminyard/gensio"
+LICENSE = "GPL-2.0-only & LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
+ file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
+ "
+
+SRCREV = "d512218c4fa5667d4fe15977d3f15f05591f1f1a"
+
+SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+PACKAGECONFIG ??= "openssl tcp-wrappers"
+
+PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
+PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
+PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
+
+EXTRA_OECONF = "--without-python"
+
+RDEPENDS:${PN} += "bash"