summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb b/meta-openembedded/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
new file mode 100644
index 0000000000..1524f096f8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "D-Bus wrapper in C++ for dbus"
+HOMEPAGE = "https://dbus-cxx.github.io/"
+BUGTRACKER = "https://github.com/libsigcplusplus/libsigcplusplus/issues"
+SECTION = "base"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
+
+SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
+ file://0001-Include-typeinfo-for-typeid.patch \
+"
+SRC_URI:append:libc-musl = "file://fix_build_musl.patch"
+SRCREV = "73532d6a5faae9c721c2cc9535b8ef32d4d18264"
+
+DEPENDS = "\
+ dbus \
+ libsigc++-3 \
+"
+
+RDEPENDS:${PN} = "\
+ dbus \
+ libsigc++-3 \
+"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"