summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb b/meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
index 9af1e3f149..f82f8e9ce2 100644
--- a/meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
+++ b/meta-openembedded/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
@@ -2,10 +2,12 @@ SUMMARY = "Toybox Inittab Configuration"
LICENSE = "BSD-0-Clause"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-0-Clause;md5=81eeb0083e31f11ab1e33ded846d521c"
+# Unpack to ${S}/orig
+#
SRC_URI = "\
- file://inittab \
- file://rcK \
- file://rcS \
+ file://inittab;subdir=${BP}/orig \
+ file://rcK;subdir=${BP}/orig \
+ file://rcS;subdir=${BP}/orig \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -15,6 +17,9 @@ RCONFLICTS_${PN} = "\
sysvinit-inittab \
"
+# Just being sure.
+B = "${S}"
+
# most users may want to have getty enabled by default
PACKAGECONFIG ??= "getty"
@@ -26,9 +31,7 @@ do_patch[noexec] = "1"
do_configure() {
# copy over files now to have a fresh start on each config
- for f in inittab rcK rcS; do
- cp ${WORKDIR}/$f ${S}
- done
+ cp orig/* .
for config in ${PACKAGECONFIG_CONFARGS}; do
if [[ ${config} == "enable_getty" ]]; then