summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-core')
-rw-r--r--meta-openembedded/meta-oe/recipes-core/libsigc++-2.0/libsigc++-3_3.0.6.bb (renamed from meta-openembedded/meta-oe/recipes-core/libsigc++-2.0/libsigc++-3_3.0.3.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2/0001-Fix-arguments-in-GLib.DBusSignalCallback-for-Vala-0..patch27
-rw-r--r--meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2_git.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-core/opencl/ocl-icd_git.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb17
-rw-r--r--meta-openembedded/meta-oe/recipes-core/toybox/toybox/0001-Tackle-SIGEMT-and-SIGSTKFLT-is-not-glibc-specific.patch30
-rw-r--r--meta-openembedded/meta-oe/recipes-core/toybox/toybox/mips-no-STKFLT.patch25
-rw-r--r--meta-openembedded/meta-oe/recipes-core/toybox/toybox_0.8.4.bb (renamed from meta-openembedded/meta-oe/recipes-core/toybox/toybox_0.8.3.bb)4
9 files changed, 48 insertions, 71 deletions
diff --git a/meta-openembedded/meta-oe/recipes-core/libsigc++-2.0/libsigc++-3_3.0.3.bb b/meta-openembedded/meta-oe/recipes-core/libsigc++-2.0/libsigc++-3_3.0.6.bb
index fc4f5d6499..7471308e4f 100644
--- a/meta-openembedded/meta-oe/recipes-core/libsigc++-2.0/libsigc++-3_3.0.3.bb
+++ b/meta-openembedded/meta-oe/recipes-core/libsigc++-2.0/libsigc++-3_3.0.6.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=959bffe2993816eb32ec4bc1ec1d5875"
DEPENDS = "mm-common"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libsigc++/3.0/libsigc++-${PV}.tar.xz"
-SRC_URI[md5sum] = "8dca4559e732f47710370baa8bc2e66f"
-SRC_URI[sha256sum] = "e4f4866a894bdbe053e4fb22ccc6bc4b6851fd31a4746fdd20b2cf6e87c6edb6"
+SRC_URI[md5sum] = "8cc0c1df6b7d9c466555f4a2963ab06a"
+SRC_URI[sha256sum] = "b70edcf4611651c54a426e109b17196e1fa17da090592a5000e2d134c03ac5ce"
S = "${WORKDIR}/libsigc++-${PV}"
diff --git a/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2/0001-Fix-arguments-in-GLib.DBusSignalCallback-for-Vala-0..patch b/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2/0001-Fix-arguments-in-GLib.DBusSignalCallback-for-Vala-0..patch
new file mode 100644
index 0000000000..65df09b1bc
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2/0001-Fix-arguments-in-GLib.DBusSignalCallback-for-Vala-0..patch
@@ -0,0 +1,27 @@
+From 01a3a35631ba3996f7e912def66b4053a4f21df9 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 3 Nov 2020 10:52:17 -0800
+Subject: [PATCH] Fix arguments in GLib.DBusSignalCallback for Vala 0.50
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/main.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/main.vala b/src/main.vala
+index 6d7132b0..b3183217 100644
+--- a/src/main.vala
++++ b/src/main.vala
+@@ -403,7 +403,7 @@ class Commands : Object
+ return false;
+ }
+
+- public void signalHandler( GLib.DBusConnection conn, string sender, string path, string iface, string name, Variant params )
++ public void signalHandler( GLib.DBusConnection conn, string? sender, string path, string iface, string name, Variant params )
+ {
+ var line = "[SIGNAL] %s.%s %s %s\n%s".printf(
+ iface,
+--
+2.29.2
+
diff --git a/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2_git.bb b/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2_git.bb
index 82f2cf8c94..71ab4d45a7 100644
--- a/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2_git.bb
+++ b/meta-openembedded/meta-oe/recipes-core/mdbus2/mdbus2_git.bb
@@ -6,7 +6,9 @@ DEPENDS = "readline"
PV = "2.3.3+git${SRCPV}"
-SRC_URI = "git://github.com/freesmartphone/mdbus.git;protocol=http"
+SRC_URI = "git://github.com/freesmartphone/mdbus.git;protocol=http \
+ file://0001-Fix-arguments-in-GLib.DBusSignalCallback-for-Vala-0..patch \
+ "
SRCREV = "28202692d0b441000f4ddb8f347f72d1355021aa"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-core/opencl/ocl-icd_git.bb b/meta-openembedded/meta-oe/recipes-core/opencl/ocl-icd_git.bb
index 937b3500c6..36355dd92c 100644
--- a/meta-openembedded/meta-oe/recipes-core/opencl/ocl-icd_git.bb
+++ b/meta-openembedded/meta-oe/recipes-core/opencl/ocl-icd_git.bb
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1238d5bccbb6bda30654e48dcc0a554b"
SRC_URI = "git://github.com/OCL-dev/ocl-icd.git;protocol=https"
-PV = "2.2.12+git${SRCPV}"
-SRCREV = "a9e57b199ff1e8d03fa3e5c53c5544de3dc72fe6"
+PV = "2.2.13+git${SRCPV}"
+SRCREV = "3b7ded60ebb7e1afddcbae6f82ac8645b276e358"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb b/meta-openembedded/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
index a4f2924755..0e29324cfd 100644
--- a/meta-openembedded/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
+++ b/meta-openembedded/meta-oe/recipes-core/opencl/opencl-clhpp_git.bb
@@ -6,8 +6,8 @@ SRC_URI = "git://github.com/KhronosGroup/OpenCL-CLHPP.git;protocol=https"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PV = "2.0.11+git${SRCPV}"
-SRCREV = "432b551429b362a877ed9b647b7114022b332be0"
+PV = "2.0.12+git${SRCPV}"
+SRCREV = "524f5ca96c3b9775f9d1debbdbcc2666bcce5c07"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-openembedded/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 4d86ef9775..e62b1eb467 100644
--- a/meta-openembedded/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-openembedded/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -192,6 +192,7 @@ RDEPENDS_packagegroup-meta-oe-crypto ="\
libsodium \
pkcs11-helper \
"
+RDEPENDS_packagegroup-meta-oe-crypto_remove_riscv32 = "botan"
RDEPENDS_packagegroup-meta-oe-dbs ="\
leveldb \
@@ -226,6 +227,7 @@ RDEPENDS_packagegroup-meta-oe-devtools ="\
${@bb.utils.contains("DISTRO_FEATURES", "x11", "geany-plugins geany", "", d)} \
lemon \
flatbuffers \
+ heaptrack \
libubox \
ltrace \
lua \
@@ -281,7 +283,7 @@ RDEPENDS_packagegroup-meta-oe-devtools ="\
xerces-c-samples \
xmlrpc-c \
yasm \
- json-schema-validator \
+ json-schema-validator \
"
RDEPENDS_packagegroup-meta-oe-devtools_append_x86 = " cpuid msr-tools pmtools"
RDEPENDS_packagegroup-meta-oe-devtools_append_x86-64 = " cpuid msr-tools pcimem pmtools"
@@ -297,8 +299,8 @@ RDEPENDS_packagegroup-meta-oe-devtools_remove_mips64el = "luajit nodejs"
RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc = "android-tools breakpad lshw luajit uftrace"
RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc64 = "android-tools lshw luajit uftrace"
RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc64le = "android-tools lshw luajit uftrace"
-RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv64 = "breakpad concurrencykit lshw ltrace luajit nodejs ply uftrace"
-RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv32 = "breakpad concurrencykit lshw ltrace luajit nodejs ply uftrace"
+RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv64 = "breakpad concurrencykit heaptrack lshw ltrace luajit nodejs ply uftrace"
+RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv32 = "breakpad concurrencykit heaptrack lshw ltrace luajit nodejs ply uftrace"
RDEPENDS_packagegroup-meta-oe-devtools_remove_aarch64 = "${@bb.utils.contains("TUNE_FEATURES", "crypto", "", "abseil-cpp", d)} concurrencykit"
RDEPENDS_packagegroup-meta-oe-devtools_remove_x86-64 = "${@bb.utils.contains("TUNE_FEATURES", "corei7", "", "abseil-cpp", d)}"
RDEPENDS_packagegroup-meta-oe-devtools_remove_x86 = "ply"
@@ -613,7 +615,10 @@ RDEPENDS_packagegroup-meta-oe-kernel_remove_riscv32 = "crash makedumpfile oprofi
RDEPENDS_packagegroup-meta-oe-multimedia ="\
alsa-oss \
${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "faad2", "", d)} \
- cdrkit \
+ dirsplit \
+ genisoimage \
+ icedax \
+ wodim \
id3lib \
audiofile \
a2jmidid \
@@ -935,6 +940,7 @@ RDEPENDS_packagegroup-meta-oe-ptest-packages_remove_arm = "numactl-ptest"
RDEPENDS_packagegroup-meta-oe-fortran-packages = "\
lapack \
octave \
+ suitesparse \
"
# library-only or headers-only packages
# They wont be built as part of images but might be interesting to include
@@ -943,9 +949,8 @@ RDEPENDS_packagegroup-meta-oe-fortran-packages = "\
# opencl-headers sdbus-c++-libsystemd boost-url nlohmann-fifo sqlite-orm
# nlohmann-json exprtk liblightmodbus p8platform gnome-doc-utils-stub
# glm ttf-mplus xbitmaps ceres-solver cli11 fftw gnulib libeigen ade
-# spdlog span-lite uthash websocketpp catch2 properties-cpp
+# spdlog span-lite uthash websocketpp catch2 properties-cpp cpp-netlib
# rsyslog conflicts with syslog-ng so its not included here
EXCLUDE_FROM_WORLD = "1"
-
diff --git a/meta-openembedded/meta-oe/recipes-core/toybox/toybox/0001-Tackle-SIGEMT-and-SIGSTKFLT-is-not-glibc-specific.patch b/meta-openembedded/meta-oe/recipes-core/toybox/toybox/0001-Tackle-SIGEMT-and-SIGSTKFLT-is-not-glibc-specific.patch
deleted file mode 100644
index faabc597ee..0000000000
--- a/meta-openembedded/meta-oe/recipes-core/toybox/toybox/0001-Tackle-SIGEMT-and-SIGSTKFLT-is-not-glibc-specific.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9e5b1420b89813ee3c58c2b792077fa8bb71f327 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 21 May 2020 13:53:27 -0700
-Subject: [PATCH] Tackle SIGEMT and SIGSTKFLT is not glibc specific
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- lib/portability.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/lib/portability.c b/lib/portability.c
-index 294141c6..1c7ebc12 100644
---- a/lib/portability.c
-+++ b/lib/portability.c
-@@ -430,8 +430,11 @@ static const struct signame signames[] = {
- // Non-POSIX signals that cause termination
- SIGNIFY(PROF), SIGNIFY(IO),
- #ifdef __linux__
--# if !defined(__GLIBC__) && !defined(__mips__)
-+# ifdef SIGSTKFLT
- SIGNIFY(STKFLT),
-+# endif
-+# ifdef SIGEMT
-+ SIGNIFY(EMT),
- # endif
- SIGNIFY(POLL), SIGNIFY(PWR),
- #elif defined(__APPLE__)
---
-2.26.2
-
diff --git a/meta-openembedded/meta-oe/recipes-core/toybox/toybox/mips-no-STKFLT.patch b/meta-openembedded/meta-oe/recipes-core/toybox/toybox/mips-no-STKFLT.patch
deleted file mode 100644
index 7ab95932cf..0000000000
--- a/meta-openembedded/meta-oe/recipes-core/toybox/toybox/mips-no-STKFLT.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-glibc on mips is missing SIGSTKFLT
-
-Do not therefore assume it being available linuxwide
-
-Fixes
-| lib/portability.c:433:3: error: use of undeclared identifier 'SIGSTKFLT'
-| SIGNIFY(STKFLT), SIGNIFY(POLL), SIGNIFY(PWR),
-| ^
-
-Upstream-Status: Submitted [https://github.com/landley/toybox/pull/195]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
---- a/lib/portability.c
-+++ b/lib/portability.c
-@@ -430,7 +430,10 @@ static const struct signame signames[] =
- // Non-POSIX signals that cause termination
- SIGNIFY(PROF), SIGNIFY(IO),
- #ifdef __linux__
-- SIGNIFY(STKFLT), SIGNIFY(POLL), SIGNIFY(PWR),
-+# if !defined(__GLIBC__) && !defined(__mips__)
-+ SIGNIFY(STKFLT),
-+# endif
-+ SIGNIFY(POLL), SIGNIFY(PWR),
- #elif defined(__APPLE__)
- SIGNIFY(EMT), SIGNIFY(INFO),
- #endif
diff --git a/meta-openembedded/meta-oe/recipes-core/toybox/toybox_0.8.3.bb b/meta-openembedded/meta-oe/recipes-core/toybox/toybox_0.8.4.bb
index 1513255c46..cc98b9ec07 100644
--- a/meta-openembedded/meta-oe/recipes-core/toybox/toybox_0.8.3.bb
+++ b/meta-openembedded/meta-oe/recipes-core/toybox/toybox_0.8.4.bb
@@ -8,10 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=78659a599b9325da368f2f1eb88f19c7"
inherit cml1 update-alternatives
SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz \
- file://mips-no-STKFLT.patch \
- file://0001-Tackle-SIGEMT-and-SIGSTKFLT-is-not-glibc-specific.patch \
"
-SRC_URI[sha256sum] = "eab28fd29d19d4e61ef09704e5871940e6f35fd35a3bb1285e41f204504b5c01"
+SRC_URI[sha256sum] = "cb2a565a8d30015d08d73628795dca51a85b99b149aeabbbecd9e8dbdbd8fddc"
SECTION = "base"