summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra.bb9
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb (renamed from meta-openembedded/meta-oe/recipes-devtools/python/python-distutils-extra.inc)10
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb4
4 files changed, 10 insertions, 15 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb b/meta-openembedded/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
index 6463f49bb5..ec1539b442 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
@@ -1,5 +1,5 @@
SUMMARY = "Python-apt is a wrapper to use features of apt from python."
-LICENSE = "GPLv2 & FSFAP"
+LICENSE = "GPL-2.0-only & FSFAP"
LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://debian/copyright;md5=4ed7b6862ca422678b17e7d4ed592285"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra.bb b/meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
deleted file mode 100644
index 580842d0d6..0000000000
--- a/meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require python-distutils-extra.inc
-
-inherit setuptools3
-
-S = "${WORKDIR}/python-distutils-extra-${PV}"
-
-RDEPENDS:${PN} = "\
- python3-setuptools \
-"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/python/python-distutils-extra.inc b/meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
index 3430cedf63..e129c18d63 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/python/python-distutils-extra.inc
+++ b/meta-openembedded/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
@@ -2,12 +2,16 @@ SUMMARY = "python-distutils extension"
DESCRIPTION = "python-distutils extension integrating gettext support, themed icons and scrollkeeper based documentation"
HOMEPAGE = "https://launchpad.net/python-distutils-extra"
SECTION = "devel/python"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
-PV = "2.39"
SRC_URI = "https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/python-distutils-extra-${PV}.tar.gz"
-SRC_URI[md5sum] = "16e06db0ef73a35b4bff4b9eed5699b5"
SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af"
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "python_distutils_extra"
+
+S = "${WORKDIR}/python-distutils-extra-${PV}"
+
BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb b/meta-openembedded/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb
index dd00f444ed..1508273009 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/python/python3-pycups_2.0.1.bb
@@ -9,11 +9,11 @@
DESCRIPTION = "pycups - CUPS bindings for Python"
HOMEPAGE = "https://github.com/OpenPrinting/pycups"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS += "cups"
# See https://pypi.org/project/pycups/ for data
SRC_URI[sha256sum] = "57434ce5f62548eb12949ca8217f066f4eeb21a5d6ab8b13471dce350e380c90"
-inherit pypi setuptools3 \ No newline at end of file
+inherit pypi python_setuptools_build_meta