summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.2.1.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.2.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.2.1.bb b/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.2.1.bb
new file mode 100644
index 0000000000..4059fd47e8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.2.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "C++ client for Redis based on hiredis"
+HOMEPAGE = "https://github.com/sewenew/redis-plus-plus"
+SECTION = "libs"
+
+DEPENDS += "hiredis"
+RDEPENDS_${PN} += "hiredis"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+SRCREV = "a9f9c301f8de1c181e6d45c573b5d1fe7b8200b1"
+SRC_URI = "git://github.com/sewenew/redis-plus-plus"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_SOLIBSDEV = ""
+FILES_${PN} += " ${libdir}/libredis++.so"