summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb (renamed from meta-openembedded/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.2.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis/redis/riscv32.patch47
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets/0001-wx-config.in-Disable-cross-magic-it-does-not-work-fo.patch35
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets_git.bb34
6 files changed, 115 insertions, 8 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.2.bb b/meta-openembedded/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb
index 24d2f7ec1e..ee75a9847c 100644
--- a/meta-openembedded/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.2.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/libpwquality/libpwquality_1.4.4.bb
@@ -9,8 +9,8 @@ SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/${SRCNAME}
file://add-missing-python-include-dir-for-cross.patch \
"
-SRC_URI[md5sum] = "ae6e61fc33f5dac0de5e847eb7520d71"
-SRC_URI[sha256sum] = "5263e09ee62269c092f790ac159112aed3e66826a795e3afec85fdeac4281c8e"
+SRC_URI[md5sum] = "1fe43f6641dbf1e1766e2a02cf68a9c3"
+SRC_URI[sha256sum] = "d43baf23dc6887fe8f8e9b75cabaabc5f4bbbaa0f9eff44278d276141752a545"
UPSTREAM_CHECK_URI = "https://github.com/libpwquality/libpwquality/releases"
diff --git a/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb b/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
index 5127e11d81..9113fa67ad 100644
--- a/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
@@ -55,6 +55,7 @@ EXTRA_OECMAKE += " \
"
EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib"
LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
+LDFLAGS_remove_riscv32 = "-fuse-ld=lld"
# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines.
COMPATIBLE_MACHINE_mips = "(!.*mips).*"
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis/redis/riscv32.patch b/meta-openembedded/meta-oe/recipes-extended/redis/redis/riscv32.patch
new file mode 100644
index 0000000000..79ec7423da
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/redis/redis/riscv32.patch
@@ -0,0 +1,47 @@
+Define correct gregs for RISCV32
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/debug.c
++++ b/src/debug.c
+@@ -942,7 +942,9 @@ static void *getMcontextEip(ucontext_t *
+ #endif
+ #elif defined(__linux__)
+ /* Linux */
+- #if defined(__i386__) || defined(__ILP32__)
++ #if defined(__riscv) && __riscv_xlen == 32
++ return (void*) uc->uc_mcontext.__gregs[REG_PC];
++ #elif defined(__i386__) || defined(__ILP32__)
+ return (void*) uc->uc_mcontext.gregs[14]; /* Linux 32 */
+ #elif defined(__X86_64__) || defined(__x86_64__)
+ return (void*) uc->uc_mcontext.gregs[16]; /* Linux 64 */
+@@ -1102,8 +1104,28 @@ void logRegisters(ucontext_t *uc) {
+ #endif
+ /* Linux */
+ #elif defined(__linux__)
++ /* Linux RISCV32 */
++ #if defined(__riscv) && __riscv_xlen == 32
++ serverLog(LL_WARNING,
++ "\n"
++ "RA:%08lx S0:%08lx S1:%08lx S2:%08lx\n"
++ "SP:%08lx PC:%08lx A0:%08lx A1:%08lx\n"
++ "A2 :%08lx A3:%08lx A4:%08lx",
++ (unsigned long) uc->uc_mcontext.__gregs[REG_RA],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_S0],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_S1],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_S2],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_SP],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_PC],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_A0 + 0],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_A0 + 1],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_A0 + 2],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_A0 + 3],
++ (unsigned long) uc->uc_mcontext.__gregs[REG_A0 + 4]
++ );
++ logStackContent((void**)uc->uc_mcontext.__gregs[REG_SP]);
+ /* Linux x86 */
+- #if defined(__i386__) || defined(__ILP32__)
++ #elif defined(__i386__) || defined(__ILP32__)
+ serverLog(LL_WARNING,
+ "\n"
+ "EAX:%08lx EBX:%08lx ECX:%08lx EDX:%08lx\n"
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb b/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb
index 64b137c1be..546332851c 100644
--- a/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/redis/redis_6.0.8.bb
@@ -15,6 +15,7 @@ SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
file://oe-use-libc-malloc.patch \
file://0001-src-Do-not-reset-FINAL_LIBS.patch \
file://GNU_SOURCE.patch \
+ file://riscv32.patch \
"
SRC_URI[md5sum] = "70113b4b8ea7ee4c7e148be62b5d1e0b"
@@ -23,6 +24,7 @@ SRC_URI[sha256sum] = "04fa1fddc39bd1aecb6739dd5dd73858a3515b427acd1e2947a66dadce
inherit autotools-brokensep update-rc.d systemd useradd
FINAL_LIBS_x86_toolchain-clang = "-latomic"
+FINAL_LIBS_riscv32_toolchain-clang = "-latomic"
FINAL_LIBS_mips = "-latomic"
FINAL_LIBS_arm = "-latomic"
FINAL_LIBS_powerpc = "-latomic"
diff --git a/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets/0001-wx-config.in-Disable-cross-magic-it-does-not-work-fo.patch b/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets/0001-wx-config.in-Disable-cross-magic-it-does-not-work-fo.patch
new file mode 100644
index 0000000000..b3b9e79c53
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets/0001-wx-config.in-Disable-cross-magic-it-does-not-work-fo.patch
@@ -0,0 +1,35 @@
+From a071243763f4b06fc7e71f541c49cecf380b6f27 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sun, 11 Oct 2020 22:16:55 +0200
+Subject: [PATCH] wx-config.in: Disable cross magic - it does not work for us
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+E.g 'wx-config --libs' appends a '-Linux' to all libraries (e.g
+-lwx_gtk3u_xrc-3.1 is reported as -lwx_gtk3u_xrc-3.1-Linux) which is wrong and
+make projects depending on wxwidgets fail.
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ wx-config.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wx-config.in b/wx-config.in
+index d132e3182f..d0d162e8a3 100755
+--- a/wx-config.in
++++ b/wx-config.in
+@@ -396,7 +396,7 @@ get_mask()
+ }
+
+ # Returns true if this script is for a cross compiled config.
+-is_cross() { [ "x@cross_compiling@" = "xyes" ]; }
++is_cross() { [ "xno" = "xyes" ]; }
+
+
+ # Determine the base directories we require.
+--
+2.26.2
+
diff --git a/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets_git.bb b/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets_git.bb
index 1d3c972da7..26a9004fb7 100644
--- a/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/wxwidgets/wxwidgets_git.bb
@@ -10,7 +10,7 @@ LICENSE = "wxWidgets"
LIC_FILES_CHKSUM = "file://docs/licence.txt;md5=981f50a934828620b08f44d75db557c6"
inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt', 'cmake_qt5', 'cmake', d)}
-inherit features_check lib_package
+inherit features_check lib_package binconfig
# All toolkit-configs except 'no_gui' require x11 explicitly (see toolkit.cmake)
REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"
@@ -21,9 +21,12 @@ DEPENDS += " \
tiff \
"
-SRC_URI = "git://github.com/wxWidgets/wxWidgets.git"
-PV = "3.1.3"
-SRCREV= "8a40d23b27ed1c80b5a2ca9f7e8461df4fbc1a31"
+SRC_URI = " \
+ git://github.com/wxWidgets/wxWidgets.git \
+ file://0001-wx-config.in-Disable-cross-magic-it-does-not-work-fo.patch \
+"
+PV = "3.1.4"
+SRCREV= "6cdaedd42ba59331b3dc4ead50e0bac76ae14c19"
S = "${WORKDIR}/git"
# These can be either 'builtin' or 'sys' and builtin means cloned soures are
@@ -39,10 +42,10 @@ EXTRA_OECMAKE_append_libc-musl = " \
-DHAVE_LOCALE_T=OFF \
"
-PACKAGECONFIG ?= "gtk"
+PACKAGECONFIG ?= "gtk ${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
# Note on toolkit-PACKAGECONFIGs: select exactly one of 'no_gui' / 'gtk' / 'qt'
-PACKAGECONFIG[no_gui] = "-DwxUSE_GUI=OFF,,,,,qt gtk"
+PACKAGECONFIG[no_gui] = "-DwxUSE_GUI=OFF,,,,,qt gtk opengl"
PACKAGECONFIG[gtk] = "-DwxBUILD_TOOLKIT=gtk3 -DwxUSE_GUI=ON,,gtk+3,,,no_gui qt"
PACKAGECONFIG[qt] = "-DwxBUILD_TOOLKIT=qt -DwxUSE_GUI=ON,,qtbase,,,no_gui gtk"
python () {
@@ -63,9 +66,28 @@ PACKAGECONFIG[gstreamer] = "-DwxUSE_MEDIACTRL=ON,-DwxUSE_MEDIACTRL=OFF,gstreamer
PACKAGECONFIG[libsecret] = "-DwxUSE_SECRETSTORE=ON,-DwxUSE_SECRETSTORE=OFF,libsecret,,,no_gui"
PACKAGECONFIG[lzma] = "-DwxUSE_LIBLZMA=ON,-DwxUSE_LIBLZMA=OFF,xz"
PACKAGECONFIG[mspack] = "-DwxUSE_LIBMSPACK=ON,-DwxUSE_LIBMSPACK=OFF,libmspack"
+PACKAGECONFIG[opengl] = ",,libglu"
PACKAGECONFIG[sdl_audio] = "-DwxUSE_LIBSDL=ON,-DwxUSE_LIBSDL=OFF,libsdl2"
PACKAGECONFIG[webkit] = "-DwxUSE_WEBVIEW_WEBKIT=ON,-DwxUSE_WEBVIEW_WEBKIT=OFF,webkitgtk,,,no_gui"
+do_compile_append() {
+ # if not at re-compile
+ if [ -L ${B}/wx-config ]; then
+ # ${B}/wx-config is a symlink for build and not needed after compile
+ # So for our purposes do:
+ # 1. make a file out of wx-config so that binconfig.bbclass detects it
+ # 2. make sure we do not move the file used for compiling into sysroot
+ cp --remove-destination `readlink ${B}/wx-config | sed 's:inplace-::'` ${B}/wx-config
+ fi
+ # 3. Set full sysroot paths so sstate can translate them when setting
+ # up wxwidgets's consumer sysroots
+ sed -i \
+ -e 's,^includedir=.*,includedir="${STAGING_INCDIR}",g' \
+ -e 's,^libdir=.*",libdir="${STAGING_LIBDIR}",g' \
+ -e 's,^bindir=.*",bindir="${STAGING_BINDIR}",g' \
+ ${B}/wx-config
+}
+
do_install_append() {
# do not ship bindir if empty
rmdir --ignore-fail-on-non-empty ${D}${bindir}