summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/fmt/fmt_10.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/fmt/fmt_10.0.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/fmt/fmt_10.0.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/fmt/fmt_10.0.0.bb b/meta-openembedded/meta-oe/recipes-support/fmt/fmt_10.0.0.bb
new file mode 100644
index 0000000000..a8e6e563da
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/fmt/fmt_10.0.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "open-source formatting library for C++"
+DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams."
+HOMEPAGE = "https://fmt.dev"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=b9257785fc4f3803a4b71b76c1412729"
+
+SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https"
+SRCREV = "a0b8a92e3d1532361c2f7feb63babc5c18d00ef2"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
+
+BBCLASSEXTEND = "native nativesdk"