summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libcereal
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libcereal')
-rwxr-xr-xmeta-openembedded/meta-oe/recipes-support/libcereal/files/run-ptest12
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb (renamed from meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.1.bb)22
2 files changed, 30 insertions, 4 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libcereal/files/run-ptest b/meta-openembedded/meta-oe/recipes-support/libcereal/files/run-ptest
new file mode 100755
index 0000000000..9bc480aa7f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libcereal/files/run-ptest
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+cd tests
+for atest in test_* ; do
+ rm -rf tests.log
+ ./${atest} > tests.log 2>&1
+ if [ $? = 0 ] ; then
+ echo "PASS: ${atest}"
+ else
+ echo "FAIL: ${atest}"
+ fi
+done
diff --git a/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.1.bb b/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
index c905b74d6e..fb37de3c30 100644
--- a/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.1.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libcereal/libcereal_1.3.2.bb
@@ -12,17 +12,31 @@ LIC_FILES_CHKSUM = "\
file://include/cereal/external/rapidjson/msinttypes/LICENSE;md5=dffce65b98c773976de2e338bd130f46 \
"
+DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} "
+
PROVIDES += "${PN}-dev"
PV .= "+git${SRCPV}"
-SRCREV = "1de8fe89471d69ea392ea260ce74e079d5f4b415"
-SRC_URI = "git://github.com/USCiLab/cereal.git;branch=master;protocol=https"
+SRCREV = "ebef1e929807629befafbb2918ea1a08c7194554"
+SRC_URI = "git://github.com/USCiLab/cereal.git;branch=master;protocol=https \
+ file://run-ptest \
+"
S = "${WORKDIR}/git"
-inherit cmake pkgconfig
+inherit cmake pkgconfig ptest
+
+LIBATOMIC:mips:toolchain-clang = "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCEREAL_THREAD_LIBS="-latomic"', '', d)}"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
+PACKAGECONFIG[with-tests] = "-DWITH_WERROR=OFF -DBUILD_TESTS=ON ${LIBATOMIC},,"
+EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '', '-DJUST_INSTALL_CEREAL=ON', d)} \
+ ${@['','-DSKIP_PORTABILITY_TEST=ON'][d.getVar('SITEINFO_BITS') != '32']}"
-EXTRA_OECMAKE = "-DJUST_INSTALL_CEREAL=ON"
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp ${B}/unittests/test_* ${D}${PTEST_PATH}/tests
+}
ALLOW_EMPTY:${PN} = "1"