summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb18
1 files changed, 13 insertions, 5 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb b/meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
index 7f205987f4..7ef4d89ce0 100644
--- a/meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libtinyxml2/libtinyxml2_9.0.0.bb
@@ -4,14 +4,22 @@ SECTION = "libs"
LICENSE = "Zlib"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
-SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
-
SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82"
+SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \
+ file://run-ptest"
S = "${WORKDIR}/git"
-inherit cmake
+inherit meson ptest
-BBCLASSEXTEND = "native"
+EXTRA_OEMESON += "${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)}"
+
+CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
-EXTRA_OECMAKE += "-Dtinyxml2_SHARED_LIBS=YES"
+do_install_ptest() {
+ install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest
+ install -d ${D}${PTEST_PATH}/resources/out
+ install -Dm 0644 ${B}/resources/*.xml ${D}${PTEST_PATH}/resources/
+}
+
+BBCLASSEXTEND = "native"