summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch32
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch29
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch24
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb10
5 files changed, 71 insertions, 28 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch b/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch
new file mode 100644
index 0000000000..61a7ac0a60
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/fix-build-with-older-gnutls.patch
@@ -0,0 +1,32 @@
+From b84ee1fa41c53c43aa7ed1583c36af5cb7c77a0f Mon Sep 17 00:00:00 2001
+From: Christian Grothoff <christian@grothoff.org>
+Date: Fri, 2 Aug 2019 15:43:44 +0200
+Subject: trying to fix #5806
+
+Upstream-Status: Backport from 0.9.67 [https://git.gnunet.org/libmicrohttpd.git/commit/?id=b84ee1fa41c53c43aa7ed1583c36af5cb7c77a0f]
+
+---
+ src/microhttpd/daemon.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/src/microhttpd/daemon.c b/src/microhttpd/daemon.c
+index bf01ba9b..a8fc98c6 100644
+--- a/src/microhttpd/daemon.c
++++ b/src/microhttpd/daemon.c
+@@ -2536,7 +2536,12 @@ internal_add_connection (struct MHD_Daemon *daemon,
+ else
+ {
+ #ifdef HTTPS_SUPPORT
+- gnutls_init_flags_t flags;
++#if (GNUTLS_VERSION_NUMBER+0 >= 0x030500)
++ gnutls_init_flags_t
++#else
++ unsigned int
++#endif
++ flags;
+
+ flags = GNUTLS_SERVER;
+ #if (GNUTLS_VERSION_NUMBER+0 >= 0x030402)
+--
+cgit v1.2.1
+
diff --git a/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb b/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb
index 7d349b94e4..6b54170049 100644
--- a/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb
@@ -6,7 +6,9 @@ SECTION = "net"
DEPENDS = "file"
-SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \
+ file://fix-build-with-older-gnutls.patch \
+"
SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9"
SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b"
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch b/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch
new file mode 100644
index 0000000000..34a1ea0fa2
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch
@@ -0,0 +1,29 @@
+From f828a89cc1e956d56498422ec158d284fc97de3f Mon Sep 17 00:00:00 2001
+From: OBATA Akio <obache@outlook.com>
+Date: Fri, 10 Aug 2018 18:38:18 +0900
+Subject: [PATCH] Fix to set libedit path from configure option properly
+
+Upstream-Status: Backport [https://github.com/uim/uim/pull/134]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 00d1b02..9c0a5ec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1311,8 +1311,8 @@ if test "x$with_libedit" != xno; then
+ if test "x$with_libedit" = xyes; then
+ libedit_path=/usr
+ else
+- with_libedit=yes
+ libedit_path="$with_libedit"
++ with_libedit=yes
+ fi
+
+ saved_CPPFLAGS=$CPPFLAGS
+--
+2.23.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch b/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
deleted file mode 100644
index 510a8c8407..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 08b5e51224ed95b1e76e99873b5f9f59840b0a74 Mon Sep 17 00:00:00 2001
-From: Lei Maohui <leimaohui@cn.fujitsu.com>
-Date: Fri, 21 Aug 2015 15:58:42 +0900
-Subject: [PATCH] fix bug for cross compile
-
-Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
-
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1317,8 +1317,8 @@ if test "x$with_libedit" != xno; then
-
- saved_CPPFLAGS=$CPPFLAGS
- saved_LDFLAGS=$LDFLAGS
-- CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
-- LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
-+ CPPFLAGS="${CPPFLAGS}"
-+ LDFLAGS="${LDFLAGS}"
- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
index cc28e6e8fd..8948ebf30f 100644
--- a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
@@ -4,11 +4,11 @@ LICENSE = "BSD-3-Clause & LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=ab2826b41ca0ff4030d38cc39791d1c8"
SECTION = "inputmethods"
-SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2"
-
+SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2 \
+ file://0001-Fix-to-set-libedit-path-from-configure-option-proper.patch \
+"
SRC_URI_append_class-target = "\
file://uim-module-manager.patch \
- file://0001-fix-bug-for-cross-compile.patch \
"
SRC_URI[md5sum] = "01c7bd5d0d4f3a9f6f5befe6f57a470b"
SRC_URI[sha256sum] = "34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc"
@@ -22,6 +22,9 @@ RDEPENDS_uim-anthy_append_libc-glibc = " glibc-utils glibc-gconv-euc-jp"
LEAD_SONAME = "libuim.so.1"
+COMPATIBLE_HOST_riscv64 = "null"
+COMPATIBLE_HOST_riscv32 = "null"
+
inherit distro_features_check autotools pkgconfig gettext qemu gtk-immodules-cache
REQUIRED_DISTRO_FEATURES = "x11"
@@ -29,6 +32,7 @@ REQUIRED_DISTRO_FEATURES = "x11"
GTKIMMODULES_PACKAGES = "uim-gtk2.0 uim-gtk3"
EXTRA_OECONF += "--disable-emacs \
+ --with-libedit=${STAGING_EXECPREFIXDIR} \
--without-scim \
--without-m17nlib \
--without-prime \