summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb (renamed from meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb)8
-rw-r--r--meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch25
-rw-r--r--meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch39
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch89
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dstat/dstat_0.7.4.bb4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/hidapi/hidapi_git.bb13
-rw-r--r--meta-openembedded/meta-oe/recipes-support/librsync/librsync_2.3.1.bb (renamed from meta-openembedded/meta-oe/recipes-support/librsync/librsync_2.3.0.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch14
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat_0.1.7.bb (renamed from meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb)17
-rw-r--r--meta-openembedded/meta-oe/recipes-support/openldap/openldap_2.4.50.bb (renamed from meta-openembedded/meta-oe/recipes-support/openldap/openldap_2.4.49.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch15
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-support/unicode-ucd/files/license.html98
-rw-r--r--meta-openembedded/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb7
14 files changed, 233 insertions, 103 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb b/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
index dd129cbec9..151653b22d 100644
--- a/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.9.0.bb
@@ -6,18 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
PV .= "+git${SRCPV}"
-SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \
- file://0001-Add-CLANG_TIDY-check.patch \
- file://0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch \
- "
+SRC_URI += "gitsm://github.com/CLIUtils/CLI11"
S = "${WORKDIR}/git"
inherit cmake
inherit ptest
-EXTRA_OECMAKE += "-DCLANG_TIDY=OFF"
-DEPENDS += "boost"
-
# cli11 is a header only C++ library, so the main package will be empty.
RDEPENDS_${PN}-dev = ""
diff --git a/meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch b/meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
deleted file mode 100644
index 02b3c9bd7e..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Add-CLANG_TIDY-check.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 902b251fd8d6408ee6623e7a92692948cf90187d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 12 Feb 2019 13:22:21 -0800
-Subject: [PATCH] Add CLANG_TIDY check
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7073a0b..2dd2c02 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -60,7 +60,7 @@ if(CMAKE_PROJECT_NAME STREQUAL PROJECT_NAME)
- endif()
- endif()
-
-- if(CMAKE_VERSION VERSION_GREATER 3.6)
-+ if(CMAKE_VERSION VERSION_GREATER 3.6 AND CLANG_TIDY)
- # Add clang-tidy if available
- option(CLANG_TIDY_FIX "Perform fixes for Clang-Tidy" OFF)
- find_program(
diff --git a/meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch b/meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch
deleted file mode 100644
index 4541cd929d..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/cli11/files/0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 8c51221f748bca1483fe1141e584867d2ff34a07 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 Dec 2019 16:26:39 -0800
-Subject: [PATCH] Use GNUInstallDirs instead of hard-coded path
-
-Upstream-Status: Submitted [https://github.com/CLIUtils/CLI11/pull/373]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7073a0b..5236fd2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -120,17 +120,18 @@ endif()
- configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake/CLI11ConfigVersion.cmake.in"
- "${CMAKE_CURRENT_BINARY_DIR}/CLI11ConfigVersion.cmake" @ONLY)
-
-+include(GNUInstallDirs)
- # These installs only make sense for a local project
- if(CUR_PROJ)
- # Make version available in the install
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CLI11ConfigVersion.cmake"
-- DESTINATION lib/cmake/CLI11)
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/CLI11)
-
- # Install the export target as a file
- install(EXPORT CLI11Targets
- FILE CLI11Config.cmake
- NAMESPACE CLI11::
-- DESTINATION lib/cmake/CLI11)
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/CLI11)
-
- # Use find_package on the installed package
- export(TARGETS CLI11
---
-2.24.1
-
diff --git a/meta-openembedded/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch b/meta-openembedded/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch
new file mode 100644
index 0000000000..06a8498f3c
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/dstat/dstat/0001-change-dstat-to-python3.patch
@@ -0,0 +1,89 @@
+From ce0528cb48666843fed2ad10ece5ecb0ac0b8cf8 Mon Sep 17 00:00:00 2001
+From: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
+Date: Fri, 15 May 2020 12:38:49 +0900
+Subject: [PATCH] change dstat to python3.
+
+Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
+---
+ dstat | 2 +-
+ examples/curstest | 2 +-
+ examples/devtest.py | 2 +-
+ examples/mmpipe.py | 2 +-
+ examples/mstat.py | 2 +-
+ examples/read.py | 2 +-
+ examples/tdbtest | 2 +-
+ 7 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/dstat b/dstat
+index 9359965..f250f06 100755
+--- a/dstat
++++ b/dstat
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ ### This program is free software; you can redistribute it and/or
+ ### modify it under the terms of the GNU General Public License
+diff --git a/examples/curstest b/examples/curstest
+index afc4e70..d720cca 100755
+--- a/examples/curstest
++++ b/examples/curstest
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ import curses, sys
+
+ #c = curses.wrapper(s)
+diff --git a/examples/devtest.py b/examples/devtest.py
+index 0e9e969..e53babd 100755
+--- a/examples/devtest.py
++++ b/examples/devtest.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+
+ import sys
+ sys.path.insert(0, '/usr/share/dstat/')
+diff --git a/examples/mmpipe.py b/examples/mmpipe.py
+index 5c93567..f91515f 100755
+--- a/examples/mmpipe.py
++++ b/examples/mmpipe.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ import select, sys, os
+
+ def readpipe(file, tmout = 0.001):
+diff --git a/examples/mstat.py b/examples/mstat.py
+index abf4d07..ac157e4 100755
+--- a/examples/mstat.py
++++ b/examples/mstat.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+
+ ### Example2: simple sub-second monitor (ministat)
+
+diff --git a/examples/read.py b/examples/read.py
+index 556b7ae..a925109 100755
+--- a/examples/read.py
++++ b/examples/read.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+
+ ### Example 1: Direct accessing stats
+ ### This is a quick example showing how you can access dstat data
+diff --git a/examples/tdbtest b/examples/tdbtest
+index 528a8ea..ae7fef9 100755
+--- a/examples/tdbtest
++++ b/examples/tdbtest
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+ import sys, tdb
+
+ db = tdb.tdb('/var/cache/samba/connections.tdb')
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-support/dstat/dstat_0.7.4.bb b/meta-openembedded/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
index 2e37dd72eb..74af54ca53 100644
--- a/meta-openembedded/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
+++ b/meta-openembedded/meta-oe/recipes-support/dstat/dstat_0.7.4.bb
@@ -9,7 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS += "asciidoc-native xmlto-native"
-SRC_URI = "git://github.com/dagwieers/dstat.git"
+SRC_URI = "git://github.com/dagwieers/dstat.git \
+ file://0001-change-dstat-to-python3.patch \
+ "
SRCREV = "6f5db0aed26bf8cf2700d4ffe90a9bd3436ac728"
diff --git a/meta-openembedded/meta-oe/recipes-support/hidapi/hidapi_git.bb b/meta-openembedded/meta-oe/recipes-support/hidapi/hidapi_git.bb
index a34797ff51..5afc4596e8 100644
--- a/meta-openembedded/meta-oe/recipes-support/hidapi/hidapi_git.bb
+++ b/meta-openembedded/meta-oe/recipes-support/hidapi/hidapi_git.bb
@@ -1,15 +1,16 @@
-SUMMARY = "Multi-platform library to interface with USB and Bluetooth HID-Class devices"
+SUMMARY = "A Simple library for communicating with USB and Bluetooth HID devices"
AUTHOR = "Alan Ott"
HOMEPAGE = "http://www.signal11.us/oss/hidapi/"
SECTION = "libs"
+
LICENSE = "BSD-3-Clause | GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7c3949a631240cb6c31c50f3eb696077"
+
DEPENDS = "libusb udev"
-PV = "0.7.99+0.8.0-rc1+git${SRCPV}"
-SRCREV = "d17db57b9d4354752e0af42f5f33007a42ef2906"
-SRC_URI = "git://github.com/signal11/hidapi.git"
+inherit autotools pkgconfig
+SRC_URI = "git://github.com/libusb/hidapi.git;protocol=https"
+PV = "0.9.0"
+SRCREV = "7da5cc91fc0d2dbe4df4f08cd31f6ca1a262418f"
S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
diff --git a/meta-openembedded/meta-oe/recipes-support/librsync/librsync_2.3.0.bb b/meta-openembedded/meta-oe/recipes-support/librsync/librsync_2.3.1.bb
index e9d34ee66a..004c93d0f9 100644
--- a/meta-openembedded/meta-oe/recipes-support/librsync/librsync_2.3.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/librsync/librsync_2.3.1.bb
@@ -5,7 +5,7 @@ LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
SRC_URI = "git://github.com/librsync/librsync.git"
-SRCREV = "028d9432d05ba4b75239e0ba35bcb36fbfc17e35"
+SRCREV = "27f738650c20fef1285f11d85a34e5094a71c06f"
S = "${WORKDIR}/git"
DEPENDS = "popt"
diff --git a/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch b/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch
index b88440dec9..f4f759c85e 100644
--- a/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch
+++ b/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch
@@ -1,4 +1,4 @@
-From 340f911f9e3f4ff6b01682c5341c959060782af2 Mon Sep 17 00:00:00 2001
+From 840795dcb48214b74cfde75e7ce5e8a1a6c64a46 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 2 Apr 2015 19:18:45 -0700
Subject: [PATCH] usb.h: Include sys/types.h
@@ -8,23 +8,21 @@ We need the definitions for things like u_intX_t
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
libusb/usb.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/libusb/usb.h b/libusb/usb.h
-index 84e730f..caffae2 100644
+index fa0e6c6..4e88eb8 100644
--- a/libusb/usb.h
+++ b/libusb/usb.h
-@@ -31,6 +31,8 @@
-
- #include <dirent.h>
+@@ -45,6 +45,8 @@ typedef unsigned __int32 uint32_t;
+ #include <stdint.h>
+ #endif
+#include <sys/types.h>
+
/*
* USB spec information
*
---
-2.1.4
-
diff --git a/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb b/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat_0.1.7.bb
index 1ddbe238fc..21fa478b6e 100644
--- a/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb
+++ b/meta-openembedded/meta-oe/recipes-support/libusb/libusb-compat_0.1.7.bb
@@ -18,15 +18,14 @@ BBCLASSEXTEND = "native nativesdk"
PE = "1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-compat-${PV}.tar.bz2 \
- file://0001-usb.h-Include-sys-types.h.patch \
- "
-
-SRC_URI[md5sum] = "2780b6a758a1e2c2943bdbf7faf740e4"
-SRC_URI[sha256sum] = "404ef4b6b324be79ac1bfb3d839eac860fbc929e6acb1ef88793a6ea328bc55a"
-
-UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libusb/files/libusb-compat-0.1/"
-UPSTREAM_CHECK_REGEX = "/libusb-compat-(?P<pver>(\d+[\.\-_]*)+)/$"
+SRC_URI = " \
+ git://github.com/libusb/libusb-compat-0.1.git;protocol=https \
+ file://0001-usb.h-Include-sys-types.h.patch \
+"
+SRCREV = "4a27760ec5954ec8605e052a3207afbe0979eeef"
+S = "${WORKDIR}/git"
+
+UPSTREAM_CHECK_URI = "https://github.com/libusb/libusb-compat-0.1/releases"
BINCONFIG = "${bindir}/libusb-config"
diff --git a/meta-openembedded/meta-oe/recipes-support/openldap/openldap_2.4.49.bb b/meta-openembedded/meta-oe/recipes-support/openldap/openldap_2.4.50.bb
index 670c704e6f..b62b13a443 100644
--- a/meta-openembedded/meta-oe/recipes-support/openldap/openldap_2.4.49.bb
+++ b/meta-openembedded/meta-oe/recipes-support/openldap/openldap_2.4.50.bb
@@ -25,8 +25,8 @@ SRC_URI = "http://www.openldap.org/software/download/OpenLDAP/openldap-release/$
file://remove-user-host-pwd-from-version.patch \
"
-SRC_URI[md5sum] = "2a47a6bb4319357ea7b032c45283e79e"
-SRC_URI[sha256sum] = "e3b117944b4180f23befe87d0dcf47f29de775befbc469dcf4ac3dab3311e56e"
+SRC_URI[md5sum] = "f9ed44ef373abed04c9e4c8586260f9e"
+SRC_URI[sha256sum] = "5cb57d958bf5c55a678c6a0f06821e0e5504d5a92e6a33240841fbca1db586b8"
DEPENDS = "util-linux groff-native"
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch b/meta-openembedded/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch
new file mode 100644
index 0000000000..adb9c4b06b
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch
@@ -0,0 +1,15 @@
+Fix error pointed out by gcc10
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/sigscheme/libgcroots/include/private/gc_priv.h
++++ b/sigscheme/libgcroots/include/private/gc_priv.h
+@@ -2026,7 +2026,7 @@ void GC_err_puts(const char *s);
+
+ # if defined(NEED_FIND_LIMIT) || \
+ defined(USE_PROC_FOR_LIBRARIES) && defined(THREADS)
+-JMP_BUF GC_jmp_buf;
++extern JMP_BUF GC_jmp_buf;
+
+ /* Set up a handler for address faults which will longjmp to */
+ /* GC_jmp_buf; */
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
index 0366ad85ae..507a341445 100644
--- a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
@@ -6,6 +6,7 @@ SECTION = "inputmethods"
SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2 \
file://0001-Fix-to-set-libedit-path-from-configure-option-proper.patch \
+ file://JMP_BUF_GC_jmp_buf.patch \
"
SRC_URI_append_class-target = "\
file://uim-module-manager.patch \
diff --git a/meta-openembedded/meta-oe/recipes-support/unicode-ucd/files/license.html b/meta-openembedded/meta-oe/recipes-support/unicode-ucd/files/license.html
new file mode 100644
index 0000000000..a02442ad97
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/unicode-ucd/files/license.html
@@ -0,0 +1,98 @@
+<!doctype HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"><html>
+
+
+
+<head>
+
+<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
+<meta http-equiv="Content-Language" content="en-us">
+<meta name="VI60_defaultClientScript" content="JavaScript">
+<meta name="GENERATOR" content="Microsoft FrontPage 12.0">
+<meta name="keywords" content="Unicode Standard, copyright">
+<meta name="ProgId" content="FrontPage.Editor.Document">
+<title>Unicode License Agreement</title>
+<link rel="stylesheet" type="text/css"
+
+href="http://www.unicode.org/webscripts/standard_styles.css">
+
+<style type="text/css">
+pre {
+ FONT-FAMILY: Arial, Geneva, sans-serif;
+}
+</style>
+
+
+</head>
+
+
+<body text="#330000">
+
+ <table width="100%" cellpadding="0" cellspacing="0" border="0">
+ <tr>
+
+ <!-- BEGIN CONTENTS -->
+
+ <td>
+
+
+<blockquote>
+<h2><a name="License">UNICODE, INC. LICENSE AGREEMENT - DATA FILES AND SOFTWARE</a></h2>
+
+<pre>
+See <a href="https://www.unicode.org/copyright.html">Terms of Use</a> for definitions of Unicode Inc.'s
+Data Files and Software.
+
+NOTICE TO USER: Carefully read the following legal agreement.
+BY DOWNLOADING, INSTALLING, COPYING OR OTHERWISE USING UNICODE INC.'S
+DATA FILES ("DATA FILES"), AND/OR SOFTWARE ("SOFTWARE"),
+YOU UNEQUIVOCALLY ACCEPT, AND AGREE TO BE BOUND BY, ALL OF THE
+TERMS AND CONDITIONS OF THIS AGREEMENT.
+IF YOU DO NOT AGREE, DO NOT DOWNLOAD, INSTALL, COPY, DISTRIBUTE OR USE
+THE DATA FILES OR SOFTWARE.
+
+COPYRIGHT AND PERMISSION NOTICE
+
+Copyright © 1991-2019 Unicode, Inc. All rights reserved.
+Distributed under the Terms of Use in https://www.unicode.org/copyright.html.
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of the Unicode data files and any associated documentation
+(the "Data Files") or Unicode software and any associated documentation
+(the "Software") to deal in the Data Files or Software
+without restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, and/or sell copies of
+the Data Files or Software, and to permit persons to whom the Data Files
+or Software are furnished to do so, provided that either
+(a) this copyright and permission notice appear with all copies
+of the Data Files or Software, or
+(b) this copyright and permission notice appear in associated
+Documentation.
+
+THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT OF THIRD PARTY RIGHTS.
+IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS
+NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL
+DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+PERFORMANCE OF THE DATA FILES OR SOFTWARE.
+
+Except as contained in this notice, the name of a copyright holder
+shall not be used in advertising or otherwise to promote the sale,
+use or other dealings in these Data Files or Software without prior
+written authorization of the copyright holder.
+</pre>
+
+</blockquote>
+
+
+
+ </td>
+
+ </tr>
+
+ </table>
+</body>
+</html>
diff --git a/meta-openembedded/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb b/meta-openembedded/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb
index 89ab565ce5..b29bb784e4 100644
--- a/meta-openembedded/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb
+++ b/meta-openembedded/meta-oe/recipes-support/unicode-ucd/unicode-ucd_12.1.0.bb
@@ -1,18 +1,15 @@
SUMMARY = "Unicode Character Database"
HOMEPAGE = "https://unicode.org/ucd/"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://unicode.org.license.html;beginline=42;endline=85;md5=67619d0c52706853c0256514e7fd04cd"
+LIC_FILES_CHKSUM = "file://../license.html;beginline=42;endline=85;md5=ddcaebcc17ab633995f12c383599f377"
SRC_URI = " \
https://www.unicode.org/Public/zipped/${PV}/UCD.zip;name=ucd;subdir=ucd \
- https://www.unicode.org/license.html;name=license;subdir=${BP};downloadfilename=unicode.org.license.html \
+ file://license.html \
"
SRC_URI[ucd.md5sum] = "430cbdac2615451571dd69a976dd08f6"
SRC_URI[ucd.sha256sum] = "25ba51a0d4c6fa41047b7a5e5733068d4a734588f055f61e85f450097834a0a6"
-SRC_URI[license.md5sum] = "f03bafb623258f85ff2032c1ce567b7c"
-SRC_URI[license.sha256sum] = "983225207de8a707d0903a8d70fb7a4b28c5e0f64f2366e84a6192a2d618fed4"
-
inherit allarch
do_configure[noexec] = "1"