summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.10.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.10.4.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.10.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.10.4.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.10.4.bb
new file mode 100644
index 0000000000..071f40bb03
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.10.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A database migration tool for SQLAlchemy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3023b042cb6002cb398344b51c67093"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "295b54bbb92c4008ab6a7dcd1e227e668416d6f84b98b3c4446a2bc6214a556b"
+
+PYPI_PACKAGE = "alembic"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-editor \
+ ${PYTHON_PN}-mako \
+ ${PYTHON_PN}-sqlalchemy \
+ ${PYTHON_PN}-misc \
+"
+
+BBCLASSEXTEND = "native nativesdk"