summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.11.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.11.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.11.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.11.1.bb
new file mode 100644
index 0000000000..feb2c419bc
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.11.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A database migration tool for SQLAlchemy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3023b042cb6002cb398344b51c67093"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "6a810a6b012c88b33458fceb869aef09ac75d6ace5291915ba7fae44de372c01"
+
+PYPI_PACKAGE = "alembic"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-editor \
+ ${PYTHON_PN}-mako \
+ ${PYTHON_PN}-sqlalchemy \
+ ${PYTHON_PN}-misc \
+"
+
+BBCLASSEXTEND = "native nativesdk"