summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
index df50bc7a89..0f1804de88 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
@@ -1,13 +1,13 @@
DESCRPTION = "ansi2html - Convert text with ANSI color codes to HTML or to LaTeX"
HOMEPAGE = "https://github.com/ralphbean/ansi2html"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3000208d539ec061b899bce1d9ce9404"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
PYPI_PACKAGE = "ansi2html"
SRC_URI[sha256sum] = "69316be8c68ac91c5582d397c2890e69c993cc7cda52062ac7e45fcb660d8edc"
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
DEPENDS += " \
${PYTHON_PN}-setuptools-scm-native \
@@ -18,8 +18,3 @@ RDEPENDS:${PN} = " \
${PYTHON_PN}-six \
${PYTHON_PN}-compression \
"
-
-do_compile:prepend() {
- echo "from setuptools import setup" > ${S}/setup.py
- echo "setup()" >> ${S}/setup.py
-}