summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_21.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_21.2.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_21.2.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_21.2.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_21.2.2.bb
new file mode 100644
index 0000000000..cc3773fc56
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_21.2.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "WebSocket client & server library, WAMP real-time framework"
+HOMEPAGE = "http://crossbar.io/autobahn"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=97c0bda20ad1d845c6369c0e47a1cd98"
+
+SRC_URI[sha256sum] = "bf7a9d302a34d0f719d43c57f65ca1f2f5c982dd6ea0c11e1e190ef6f43710fe"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-zopeinterface \
+ ${PYTHON_PN}-py-ubjson \
+ ${PYTHON_PN}-cbor2 \
+ ${PYTHON_PN}-u-msgpack-python \
+ ${PYTHON_PN}-lz4 \
+ ${PYTHON_PN}-snappy \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-txaio \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"