summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_23.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_23.1.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_23.1.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_23.1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_23.1.1.bb
new file mode 100644
index 0000000000..b67e900685
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-autobahn_23.1.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "WebSocket client & server library, WAMP real-time framework"
+HOMEPAGE = "http://crossbar.io/autobahn"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3e2c2c2cc2915edc5321b0e6b1d3f5f8"
+
+SRC_URI[sha256sum] = "a88882ab4700ee9eee46c69c38e2b625f6fda48ab1ce61cf7b58b23cf2fadcb8"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-zopeinterface \
+ ${PYTHON_PN}-py-ubjson \
+ ${PYTHON_PN}-cbor2 \
+ ${PYTHON_PN}-u-msgpack-python \
+ ${PYTHON_PN}-lz4 \
+ ${PYTHON_PN}-snappy \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-txaio \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"