summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
index 7411a749db..07d86cfc5d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cachetools_4.1.0.bb
@@ -8,7 +8,20 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
SRC_URI[md5sum] = "4468da43443115a00c02c126cf601ae0"
SRC_URI[sha256sum] = "1d057645db16ca7fe1f3bd953558897603d6f0b9c51ed9d11eb4d071ec4e2aab"