summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb
new file mode 100644
index 0000000000..7e9b262d11
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-coverage_7.0.3.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Code coverage measurement for Python"
+HOMEPAGE = "https://coverage.readthedocs.io"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[sha256sum] = "d5be4e93acce64f516bf4fd239c0e6118fc913c93fa1a3f52d15bdcc60d97b2d"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-toml \
+ ${PYTHON_PN}-multiprocessing \
+"