summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-dbus-fast_2.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-dbus-fast_2.12.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-dbus-fast_2.12.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-dbus-fast_2.12.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-dbus-fast_2.12.0.bb
new file mode 100644
index 0000000000..05502e223b
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-dbus-fast_2.12.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A faster version of dbus-next originally from the great DBus next library."
+HOMEPAGE = "https://github.com/bluetooth-devices/dbus-fast"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=729e372b5ea0168438e4fd4a00a04947"
+
+SRC_URI[sha256sum] = "849478e11d251fa4ebb99ce5bfee332cb6383c63ef0bc97bae23cef4e0badf9c"
+
+PYPI_PACKAGE = "dbus_fast"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-core (>=3.7) \
+ python3-async-timeout \
+"