summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
index ce4dfdc74a..cb255442f4 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-dnspython_1.16.0.bb
@@ -1,2 +1,20 @@
-inherit setuptools3
-require python-dnspython.inc
+DESCRIPTION = "DNS toolkit for Python"
+HOMEPAGE = "http://www.dnspython.org/"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
+
+SRC_URI[md5sum] = "bc9ca3b3a82164667d5730ec6d5248a2"
+SRC_URI[sha256sum] = "36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c558e01"
+
+PYPI_PACKAGE_EXT = "zip"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+"