summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-socketio_5.3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-flask-socketio_5.3.4.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-flask-socketio_5.3.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-socketio_5.3.4.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-socketio_5.3.4.bb
new file mode 100644
index 0000000000..4dae0d14ba
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-socketio_5.3.4.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Socket.IO integration for Flask applications"
+HOMEPAGE = "https://github.com/miguelgrinberg/Flask-SocketIO/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=38cc21254909604298ce763a6e4440a0"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "Flask-SocketIO"
+
+SRC_URI[sha256sum] = "1cbd379c9bf68ac37bcc4750d01708922fa6365d13a5447d3f8893792879410c"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-socketio \
+ "