summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb
new file mode 100644
index 0000000000..2bf9d07533
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.6.7.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Client for MQTT protocol"
+HOMEPAGE = "https://github.com/wialon/gmqtt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=903f1792621a3b35ee546da75d139177"
+
+SRC_URI[md5sum] = "9e26fec7d5b64afab63d6d82faacc208"
+SRC_URI[sha256sum] = "86b3679de400b8068dfadf871ce063a7040ed5052d30cc323aed69430888b422"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-asyncio \
+ python3-core \
+ python3-datetime \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-typing \
+"
+
+BBCLASSEXTEND = "native nativesdk"