summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb
index 18cf8ae8b5..2d3b8772db 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-gpiod_2.0.bb
@@ -18,7 +18,11 @@ S = "${WORKDIR}/libgpiod-2.0/bindings/python"
inherit setuptools3 ptest
DEPENDS += "libgpiod"
-RDEPENDS:${PN} += "libgpiod (>= 2.0)"
+RDEPENDS:${PN} += " \
+ libgpiod (>= 2.0) \
+ python3-datetime \
+ python3-profile \
+"
RDEPENDS:${PN}-ptest += "python3-setuptools"
export GPIOD_WITH_TESTS = "${@bb.utils.contains("PTEST_ENABLED", "1", "1", "0", d)}"