summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch27
1 files changed, 15 insertions, 12 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index f416ca2728..1f465dbb6e 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -23,16 +23,17 @@ Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
- setup.py | 9 ++++++---
- src/python/grpcio/commands.py | 5 ++++-
- 2 files changed, 10 insertions(+), 4 deletions(-)
+ setup.py | 11 +++++++----
+ src/python/grpcio/commands.py | 5 ++++-
+ 2 files changed, 11 insertions(+), 5 deletions(-)
diff --git a/setup.py b/setup.py
-index ec27fe4..b2d2d1a 100644
+index 3a50c97..bb2386d 100644
--- a/setup.py
+++ b/setup.py
-@@ -206,8 +206,11 @@ def check_linker_need_libatomic():
+@@ -205,8 +205,11 @@ def check_linker_need_libatomic():
"""Test if linker on system needs libatomic."""
code_test = (b'#include <atomic>\n' +
b'int main() { return std::atomic<int64_t>{}; }')
@@ -46,15 +47,17 @@ index ec27fe4..b2d2d1a 100644
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)
-@@ -217,7 +220,7 @@ def check_linker_need_libatomic():
+@@ -215,8 +218,8 @@ def check_linker_need_libatomic():
+ return False
# Double-check to see if -latomic actually can solve the problem.
# https://github.com/grpc/grpc/issues/22491
- cpp_test = subprocess.Popen(
-- [cxx, '-x', 'c++', '-std=c++14', '-', '-latomic'],
-+ [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'],
- stdin=PIPE,
- stdout=PIPE,
- stderr=PIPE)
+- cpp_test = subprocess.Popen(cxx +
+- ['-x', 'c++', '-std=c++14', '-', '-latomic'],
++ cpp_test = subprocess.Popen(
++ [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'],
+ stdin=PIPE,
+ stdout=PIPE,
+ stderr=PIPE)
diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py
index d93b6c7..a8c4a51 100644
--- a/src/python/grpcio/commands.py