summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_4.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_4.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_4.1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_4.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_4.1.0.bb
new file mode 100644
index 0000000000..df5a4e9d52
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_4.1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Python humanize utilities"
+HOMEPAGE = "http://github.com/jmoiron/humanize"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
+
+SRC_URI[sha256sum] = "3a119b242ec872c029d8b7bf8435a61a5798f124b244a08013aec5617302f80e"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "\
+ ${PYTHON_PN}-setuptools-scm-native \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-setuptools \
+"
+
+BBCLASSEXTEND = "native nativesdk"