summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
new file mode 100644
index 0000000000..016bafc134
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Incremental is a small library that versions your Python projects"
+HOMEPAGE = "https://github.com/twisted/incremental"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
+
+SRC_URI[sha256sum] = "912feeb5e0f7e0188e6f42241d2f450002e11bbc0937c65865045854c24c0bd0"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-click \
+"
+
+# -native is needed to build python[3]-twisted, however, we need to take steps to
+# prevent a circular dependency. The build apparently does not use the part of
+# python-incremental which uses python-twisted, so this hack is OK.
+RDEPENDS:${PYTHON_PN}-incremental-native:remove = "${PYTHON_PN}-twisted-native"
+BBCLASSEXTEND = "native"