summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
index 016bafc134..3d93cc05e9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
@@ -8,12 +8,12 @@ SRC_URI[sha256sum] = "912feeb5e0f7e0188e6f42241d2f450002e11bbc0937c65865045854c2
inherit pypi setuptools3
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-twisted \
- ${PYTHON_PN}-click \
+ python3-twisted \
+ python3-click \
"
# -native is needed to build python[3]-twisted, however, we need to take steps to
# prevent a circular dependency. The build apparently does not use the part of
# python-incremental which uses python-twisted, so this hack is OK.
-RDEPENDS:${PYTHON_PN}-incremental-native:remove = "${PYTHON_PN}-twisted-native"
+RDEPENDS:python3-incremental-native:remove = "python3-twisted-native"
BBCLASSEXTEND = "native"