summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb
index 73efceeed3..8ec21ff11c 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb
@@ -1,2 +1,11 @@
-inherit setuptools3
-require python-jsonpatch.inc
+SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "fcc546892414bef2f7f89f0e2a618a9e"
+SRC_URI[sha256sum] = "ddc0f7628b8bfdd62e3cbfbc24ca6671b0b6265b50d186c2cf3659dc0f78fd6a"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-stringold"