summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-core_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-luma-core_2.4.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-luma-core_2.4.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-core_2.4.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-core_2.4.0.bb
new file mode 100644
index 0000000000..8a7be0a30c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-core_2.4.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "A component library to support SBC display drivers"
+DESCRIPTION = "A component library to support SBC display drivers"
+HOMEPAGE = "https://github.com/rm-hull/luma.core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=71cded473ab60fdbe20edc519217f521"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "cf5fdf3563d5ec56e2f792f3a2f432abaeac517a0b05a10a757a4c5a26bb2e5d"
+
+PYPI_PACKAGE = "luma.core"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-pillow \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-smbus2 \
+"