summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.971.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.971.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.971.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
new file mode 100644
index 0000000000..31fcb06c9e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
+HOMEPAGE = "https://github.com/python/mypy"
+LICENSE = "MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
+
+PYPI_PACKAGE = "mypy"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
+
+BBCLASSEXTEND = "native"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-mypy-extensions \
+ ${PYTHON_PN}-typed-ast \
+ ${PYTHON_PN}-typing-extensions \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-toml \
+"