summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_1.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_1.6.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_1.6.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_1.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_1.6.1.bb
new file mode 100644
index 0000000000..fe9e3e3864
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_1.6.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
+HOMEPAGE = "https://github.com/python/mypy"
+LICENSE = "MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "4d01c00d09a0be62a4ca3f933e315455bde83f37f892ba4b08ce92f3cf44bcc1"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += " \
+ python3-mypy-extensions-native \
+ python3-types-psutil-native \
+ python3-types-setuptools-native \
+ python3-typing-extensions-native \
+"
+
+RDEPENDS:${PN} += " \
+ python3-modules \
+ python3-mypy-extensions \
+ python3-typing-extensions \
+"