summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-nmap_1.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-nmap_1.5.4.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-nmap_1.5.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-nmap_1.5.4.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-nmap_1.5.4.bb
new file mode 100644
index 0000000000..828d7089b2
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-nmap_1.5.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "python-nmap is a python library which helps in using nmap port scanner"
+HOMEPAGE = "https://www.nmmapper.com/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS += "${PYTHON_PN}-wheel-native"
+
+PYPI_PACKAGE = "python3-nmap"
+
+SRC_URI[sha256sum] = "cd5b0180d4d8cfe96c33e5e7956fa011379af108e2e8291b84e933b6385856e9"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "nmap \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-simplejson \
+"