summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-paramiko_2.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-paramiko_2.11.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-paramiko_2.11.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-paramiko_2.11.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-paramiko_2.11.0.bb
new file mode 100644
index 0000000000..5c0cb1e1a6
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-paramiko_2.11.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "The leading native Python SSHv2 protocol library."
+HOMEPAGE = "https://github.com/paramiko/paramiko/"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fd0120fc2e9f841c73ac707a30389af5"
+
+SRC_URI[sha256sum] = "003e6bee7c034c21fbb051bf83dc0a9ee4106204dd3c53054c71452cc4ec3938"
+
+PYPI_PACKAGE = "paramiko"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-bcrypt \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-pynacl \
+ ${PYTHON_PN}-unixadmin \
+"