summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-platformdirs_3.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-platformdirs_3.11.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-platformdirs_3.11.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-platformdirs_3.11.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-platformdirs_3.11.0.bb
new file mode 100644
index 0000000000..5a65d67706
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-platformdirs_3.11.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE = "https://github.com/platformdirs/platformdirs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+SRC_URI[sha256sum] = "cf8ee52a3afdb965072dcc652433e0c7e3e40cf5ea1477cd4b3b1d2eb75495b3"
+
+inherit pypi python_hatchling ptest
+
+DEPENDS += " \
+ ${PYTHON_PN}-hatch-vcs-native \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-appdirs \
+ ${PYTHON_PN}-covdefaults \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytest-mock \
+ ${PYTHON_PN}-pytest-cov \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -rf ${S}/tests ${D}${PTEST_PATH}/
+}
+
+BBCLASSEXTEND = "native nativesdk"