summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb
new file mode 100644
index 0000000000..a065b6c475
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_1.0.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Python library for displaying tabular data in a ASCII table format"
+HOMEPAGE = "http://code.google.com/p/prettytable"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671"
+
+SRC_URI[md5sum] = "b5bd0acec56ae7ccf5ac22d3f671c3a7"
+SRC_URI[sha256sum] = "6bb7f539903cb031fecb855b615cbcac8cd245ebc6fa51c6e23ab3386db89771"
+
+do_install_append() {
+ perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
+ for f in $perm_files; do
+ chmod 644 "${f}"
+ done
+}
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
+UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
+
+BBCLASSEXTEND = "native nativesdk"
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-html \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
+}