summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb28
1 files changed, 15 insertions, 13 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
index f94ef3637b..78662fe3cd 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
@@ -2,31 +2,33 @@ SUMMARY = "Seamless operability between C++11 and Python"
HOMEPAGE = "https://github.com/pybind/pybind11"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
+DEPENDS = "\
+ python3-cmake-native \
+ python3-ninja-native \
+"
SRCREV = "8a099e44b3d5f85b20f05828d919d2332a8de841"
-SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https"
+SRC_URI = "\
+ git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
+ file://0001-Do-not-strip-binaries.patch \
+"
S = "${WORKDIR}/git"
-inherit cmake setuptools3
+inherit cmake python_setuptools_build_meta
EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
-PIP_INSTALL_DIST_PATH = "${S}/dist"
-PIP_INSTALL_PACKAGE = "pybind11"
-
-do_configure() {
- cmake_do_configure
+do_configure:append() {
+ cmake_do_configure
}
-do_compile() {
- setuptools3_do_compile
- cmake_do_compile
+do_compile:append() {
+ cmake_do_compile
}
-do_install() {
- setuptools3_do_install
- cmake_do_install
+do_install:append() {
+ cmake_do_install
}
BBCLASSEXTEND = "native nativesdk"