summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
index 46bba8d8d1..9674ec0938 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
@@ -17,4 +17,18 @@ BBCLASSEXTEND = "native"
EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
-inherit cmake python3native
+inherit cmake setuptools3 python3native
+
+do_configure() {
+ cmake_do_configure
+}
+
+do_compile() {
+ distutils3_do_compile
+ cmake_do_compile
+}
+
+do_install() {
+ distutils3_do_install
+ cmake_do_install
+}