summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_13.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_13.0.6.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_13.0.6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_13.0.6.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_13.0.6.bb
new file mode 100644
index 0000000000..2d9efa3906
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_13.0.6.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
+HOMEPAGE = "https://github.com/balloob/pychromecast"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
+
+SRC_URI[sha256sum] = "149dad28cbed2296b5074c326662d9cb0093b834b417cb9ee05828e97b282e73"
+
+PYPI_PACKAGE = "PyChromecast"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-zeroconf \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-protobuf \
+ ${PYTHON_PN}-compression \
+"