summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pymetno_0.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pymetno_0.10.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pymetno_0.10.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pymetno_0.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pymetno_0.10.0.bb
new file mode 100644
index 0000000000..c5ab635927
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pymetno_0.10.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python library to talk to the met.no api"
+HOMEPAGE = "https://github.com/Danielhiversen/pyMetno"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d503272f52c35147ec960cb56a03bf4"
+
+SRC_URI = "git://github.com/Danielhiversen/pyMetno.git;protocol=https;branch=master"
+SRCREV = "5fc18d7c5d627a9d9b2529db98d4e7e01a37dbf9"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "PyMetno"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-aiohttp (>=3.6.1) \
+ ${PYTHON_PN}-async-timeout (>=3.0.1) \
+ ${PYTHON_PN}-pytz (>=2019.3) \
+"