summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
index 0747c67c19..a2f2ab4df4 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
@@ -11,7 +11,7 @@ PYPI_PACKAGE = "PyNaCl"
inherit pypi python_setuptools_build_meta
DEPENDS += "\
- ${PYTHON_PN}-cffi-native \
+ python3-cffi-native \
libsodium \
"
@@ -24,8 +24,8 @@ do_install:prepend() {
}
RDEPENDS:${PN} = "\
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-cffi \
+ python3-six \
+ python3-cffi \
libsodium \
"
@@ -34,3 +34,5 @@ RPROVIDES:${PN} = "python3-nacl"
# in meta-virtualization layer
#
RCONFLICTS:${PN} = "python3-nacl"
+
+BBCLASSEXTEND = "native nativesdk"