summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
index da263fe94e..da22a43deb 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
@@ -4,10 +4,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
SRC_URI[sha256sum] = "d74a814bfda01085db1a8ad90be3cb27daf23a51ab6b03e7e29ec811fa2ae859"
-DEPENDS = "systemd"
+DEPENDS = "systemd python3-cython-native"
RDEPENDS:${PN} += "python3-xml python3-pprint"
REQUIRED_DISTRO_FEATURES = "systemd"
inherit pypi setuptools3 features_check pkgconfig
+do_configure:prepend() {
+ rm -rf ${S}/pystemd/*.c
+}
+
BBCLASSEXTEND = "native"