summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
index e7a6c21085..f132d91a69 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzstd_0.15.7.bb
@@ -11,3 +11,8 @@ PYPI_PACKAGE = "pyzstd"
SRC_URI[sha256sum] = "55e503f28f5a9d225ce9d0639e3f5b1801bacace5aea926ec2998e73c5150fe7"
inherit pypi setuptools3
+
+# clang-16 with -flto segfaults on arm, therefore ignore flto for now
+do_configure:append:arm:toolchain-clang() {
+ sed -i -e "s|'-flto'|''|" ${S}/setup.py
+}