summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb
new file mode 100644
index 0000000000..1853596b46
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Snagboot intends to be an open-source replacement vendor-specific tools used to recover and/or reflash embedded platforms."
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI[sha256sum] = "c2d21cadddecfd97dd62a8b66b6f88bd56272627b9b71272e9dda6f868ee8715"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += " \
+ bash \
+ python3-fcntl \
+ python3-pyusb \
+ python3-pyyaml \
+ python3-setuptools \
+ python3-six \
+"
+
+do_install:append() {
+ install -D -m 0644 ${S}/src/snagrecover/80-snagboot.rules ${D}${sysconfdir}/udev/rules.d/80-snagboot.rules
+}