summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
index a0167cf03b..3786ccb855 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
@@ -6,7 +6,22 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
SRC_URI[md5sum] = "411df8eefd76ffa014328a46342bdf38"
SRC_URI[sha256sum] = "529ef3d88189cc457f4340388028412f71be8091c2c943465146d4170fb67288"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-typing-extensions \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
DEPENDS += "\
python3-distutils-extra-native \